christophedlr

Impossible de charger les polices

33 posts in this topic

Bonjour,

 

Je ne sais pas si je dois poster dans la section HL ou CS car les deux sont touchés (en fait tout les jeux Valve du moteur source).

 

Ca fait plusieurs mois, que je ne peux jouer que se soit à HL² ou CS:Source (ou même CS:GO), car la police de caractère ne se charge pas.

 

Dans la console, le jeu me dit : "Failed to load custom font file" et ceci pour chaque police d'écriture du jeu. Et en effet, Windows me dit que les fichiers TTF en question, ne sont pas valide, mais j'ai beau les supprimés, Steam me retélécharge toujours les même.

 

Ca me fait ça depuis mon passage sous Windows 10. J'ai testé en mettant le jeu en compatibilité Windows 7, mais ça change rien, pour lui les TTF sont invalides et il ne peut donc pas les charger.

 

Quelqu'un a déjà eu le soucis et si oui, a pu le corriger ?

 

Merci d'avance pour votre aide.

Share this post


Link to post
Share on other sites

Oui, déjà essayé que se soit CS:Source/CS:GO ou même Half-Life².

Cela faisait 2 mois qu'ils étaient désinstallés, dossiers supprimer etc., là j'ai réinstallé CS:Source hier soir et c'est là que ce matin en le lançant, je découvre que j'ai toujours le soucis.

 

En fait j'ai fais la migration vers Windows 10 le jour de sa sortie (le 29 juillet 2015), et depuis j'ai ce soucis quand j'ai tenté de joué mi décembre 2015 quand j'ai eu mes précédentes vacances.

 

Autant la police de caractère remplacer par des b, l, p etc. dans la barre de status du HUD, ça me dérange pas spécialement, autant le viseur à la con qui se trouve être au final une lettre, c'est beaucoup plus dérangeant.

Share this post


Link to post
Share on other sites

Ok, merci pour les informations. Je verrais pour le faire quand j'aurais le temps, car derrière faut tout réinstaller, reconfigurer etc. ; pas vraiment le temps en ce moment.

 

C'est justement parce que j'ai rien trouvé chez mon ami Google que je suis venu demander de l'aide ^^

Share this post


Link to post
Share on other sites

C'est chiant les réinstallations, je suis d'accord avec toi.

 

Tout reconfigurer, réinstaller les apps et les pilotes, etc.

Ca prends du temps, surtout quand on est méticuleux (comme moi :ph34r:).

Share this post


Link to post
Share on other sites

Au pire je peux créer un script pour automatiser le lancement d'installation des pilotes etc. suffit juste que j'ai dl avant, c'est juste que j'ai un tas de trucs sur mon PC, donc faut tout sauvegarder (ca c'est fait souvent avec un logiciel spécial donc pas de soucis), faut que je fasse du tri surtout et là je n'ai pas le temps ni la motivation lol.

 

Après oui possible que la migration se soit mal passée, car comme je l'ai faite dès le premier jour. J'ai déjà eu un soucis de migration des droits utilisateurs cela dit.

 

En tout cas merci pour votre aide les gars, dommage qu'on ai pas trouvé la solution au problème. Je vais essayer de voir si je trouve un logiciel de lecture des TTF (au pire un petit programme en SFML/C++ fait en vitesse pour lire directement les fonts) pour voir si elles sont réellement illisibles ou non, ça permettrait de mieux cerner le soucis.

 

Sinon un de ces jours, faudra que je tente carrément une désinstallation totale de Steam et tout les jeux Steam, puis réinstallation ; avec de la chance ça corrigerais le soucis lol.

Ce que je ne comprend pas surtout, c'est qu'il doit pas réussir à lire les TTF,  donc en accès directe et non en accès via C:\windows\fonts, ce qui me laisse à penser que ce sont bien les TTF en question qui ont un problème.

 

EDIT : Bon je viens de tester avec le logiciel FontForge, il lit sans problème les TTF, mais il trouve des erreurs dans la création des polices. C'est pareil d'ailleurs avec toutes les polices déjà installées dans C:\windows\fonts, et aucune si je copie le fichier ailleurs et fait un double-clique ne fonctionne pour lui (d'après lui elles sont toutes invalides, pourtant webdings je m'en suis déjà servis lol, tahomas etc. aussi).

 

Donc oui ça semble être clairement Windows qui a une couille dans son potage, mais alors pourquoi il arrive à lire les polices déjà installées quand même et pas une lecture directe d'un TTF ? Je n'en sais rien lol.

Edited by christophedlr

Share this post


Link to post
Share on other sites

Threshold 2 ? Je sais pas, tout ce que je sais c'est que j'ai migré de Windows 7 à Windows 10 le jour de sa sortie (29/07/2015), et les mises à jour sont faites automatiquement (et là il est a jour).

Share this post


Link to post
Share on other sites

Pouet,

 

Avant de reformater as tu essayé de mettre une tild devant le répertoire de ton jeu ? à une époque ça réinitialiser les paramétres du jeu.

 

exemple : C:\Program Files\Steam\SteamApps\<compte>\~counter strike GO

 

Attention je ne dis pas que ça va marcher, mais à une époque c'était utile :)

 

Tiens nous au jus !

Share this post


Link to post
Share on other sites

Windows 10 édition familiale (j'étais avant sous Windows 7 Home Premium). Tu penses que cela change quelque chose ?

 

Cliques sur Démarrer et tape "winver" (sans les guillemets) pour connaitre ta version de Windows.

Moi par exemple, je suis sous la version 1511 (10586.164)

 

Si tu as moins récent que moi, je t'invite à mettre à jour via mon lien plus haut.

Tu ne perdras rien de tes données ni de tes applications.

 

Aussi, as tu déjà essayé une vérification avec cette commande (dans l'invite de commandes en admin) ?

DISM /Online /Cleanup-Image /RestoreHealth

Share this post


Link to post
Share on other sites

Lui il me dit juste : "Version 10.0 (numéro 10240)", cf. screenshot :

1459366519-winver.png

 

Pour ce qui est de ton lien, c'est pour faire la migration, enfin bon je suis entrain de tenter au cas où mais une fois qu'il aura fini le download je doute qu'il puisse faire une migration de Windows 10 à Windows 10 lol.

 

Quand à ta dernière commande, je viens aussi de la lancer, on verra ce que ça donne.

 

EDIT : Concernant ta dernière commande, il m'indique que la restauration a été effectuée et que l'opération a réussi, toutefois rien ne change, même sur une police normale Windows me dit que ce n'est pas une police valide. Et le logiciel FontForge (open-source), me dit toujours qu'il y a des problèmes avec les extrémités des points sur chacun des caractères de la police, je viens de tester avec Arial.

Edited by christophedlr

Share this post


Link to post
Share on other sites

Si si ca te permettra de mettre à jour ta version de Windows ;)

Mais meme si après ça, le problème est toujours présent, alors je ne vois rien d'autre qu'une réinstallation complète :(

Share this post


Link to post
Share on other sites

Ok, ben pour l'instant il est sur une recherche des mises à jour et ce depuis une bonne mon EDIT, donc depuis 22h09.

 

Cela dit cette version en question, c'est pour les programs insider peut être, moi j'ai pas coché pour bénéficier des maj avant la sortie officielle, pour m'assurer de garder un windows stable.

Share this post


Link to post
Share on other sites

Je reviens, parce que ça n'a rien changé, je suis toujours sur la même version, donc il semble que non ce soit pas fournis à tous depuis fin 2015, ou alors Windows a des râtés et n'est pas fichu de trouver les mises à jour.

 

Je viens de regarder, la seule maj qu'il me propose c'est toujours la même : pour mon imprimante Brother, et il n'est pas fichu d'installer la mise à jour et ce depuis la migration (lol).

 

EDIT : Alors qu'au départ il m'avait plusieurs fois proposé des mises à jour, en fait j'avais pas vu qu'il avait configuré sur "PC réseau local" et non "PC réseau local et internet", c'est peut être pour ça que j'avais plus de maj depuis un bon moment.

 

Je viens de l'activer, j'attends qu'il est terminé son cirque avec le driver Brother, et je ferais les maj manquantes ; on verra si ça corrige le soucis ^^

Edited by christophedlr

Share this post


Link to post
Share on other sites

Au pire des cas, tu peux passer par là et chopper l'iso le plus récent de W10 :

 

https://www.microsoft.com/fr-fr/software-download/techbench

 

Tout comme toi, windows update ne me proposait pas la mise à jour alors que j'ai installé Win10 en juillet dernier.
J'ai finalement utilisé cet iso ce soir avec la dégringolade que m'a fait mon pilote ethernet.

Share this post


Link to post
Share on other sites

Je viens de voir que j'étais pas revenu sur le topic lol. Donc non rien n'a changé, je vais voir ton lien Dr.Doc, mais bon avec mon stage toute la semaine, il me reste que le week-end pour avancer mon projet et jouer un peut, donc je verrais ça après la formation (fin juin environ).

Share this post


Link to post
Share on other sites

Rien n'a changé en faisant cette mise à jour ??

 

Je crains qu'il ne te reste que la réinstallation complète du coup :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now