Saccade pendant le jeu malgré un ping correct et fps ok


troisni60

Recommended Posts

Bonjour à tous,

Bon après avoir écrit un roman et plantage du pc je vais faire plus court.

Je reprends cz après 2 ans sans jouer. Ma config actuelle, carte mère asus kbv-x, carte graphique radeon 9600 pro 256Mo, Athlon 64 3000+ 2Ghz, 1.75 Mo ram. Avant je tournais avec une moins bonne config et ça marchais bien.

En fait le soucis c'est que quand je me retrouve face à d'autre persos ça saccade, c'est pas fluide, enfin bref ça lag. Le problème c'est que le fps est ok (99) et mon ping est ne dépasse pas 50. Si ma cible est loin là c'est ok c'est fluide, par contre si un coéquipier ou 2 passe devant ça lag. J'ai testé tout seul sur un serveur et là ça marche bien, aucunes saccades.

Je pense que c'est un problème vidéo, avec la carte graphique mais impossible de trouver. Je joue en 1280*1024, 32bit en OpenGL ; j'ai testé en 1024*768 et même en 800*600 mais rien n'y fait toujours ce bug... j'ai même cru un moment que c'était la souris mais après plusieurs test il s'est vérifié que non.

J'ai essayé en coupant mon spyware et avast (après analyses bien sûr) et toujours rien.

Pour info si ça peut aider, je suis sous XP, SP2, Directx 9.c.

Je vous remercie par avance pour vos réponse en espérant en avoir.

"Edit" : J'ai désintallé et réinstallé cs, aucun changement ; en regardant bien mon fps baissait qd même vers 50 sur des maps bourin (euh comme pool et autres...)

Merci d'avance pour vos réponses.

Denis

Link to comment
Share on other sites

un lag est un décalage lié à un ping élevé OU à une mauvaise qualité de connexion (le lag ne se "lit" pas dans le ping contrairement à ce que beaucoup pensent...).

Un jeu qui rame est un jeu lent, saccadé, c'est plus généralement lié à la machine. Ce qu'on constate souvent quand on met toutes le options graphiques à fond et que le pc ne suit pas.

Parfois les deux se mélangent...

Ok pour les bots, si possible, j'aimerais savoir ce que ça donne en partie lan avec d'autres joueurs humains si tu peux...

Link to comment
Share on other sites

Ok merci pour les explications, donc peut-être que c'est dû à ma machine (carte graphique ?)

Pour la lan ça va pas être possible, par contre ce we j'ai eu l'avis de quelqu'un qui s'y connait pas mal et qui m'a dit de nettoyer un peu ma tour de la poussière pour voir ; sinon il m'a dit que ati tourne moins que Geforce pour les jeux et que si pour environ 200 € je pourrai changer ma config et avoir quelque chose de sympa...

N'empêche que c'est bizarre si c'est la carte graphique, avant j'avais une geforce mx420 et ça tournait bien.

Cet aprem je nettoie ma tour, on sait jamais et je retest après.

Link to comment
Share on other sites

Ta carte graphique est une carte intégrée à la carte mère ?

Si oui ça peut expliquer ton problème...

Mais l'explication de ton pote que "s'y connait pas mal" ne tient pas la route (nettoyer, ok, à la rigueur, mais à mon humble avis ça ne changera rien), acheter une carte graphique à 200€ pour un jeu qui a 10 ans... heu, c'est très très con hein. Une carte à 30€ suffit largement.

Mais pour moi c'est pas évident que ça vienne directement de ta carte. Peut être un soucis de pilotes. Peut être des processus de windows qui analyse les paquets de données (essaye de désactiver ton antivirus quand tu joues, juste pour faire le test)

Link to comment
Share on other sites

Et ta une solution si la carte graphique est intégré ?? Ca se pourrait que oui pour moi

EDIT = J'ai jouer en 2V2 sur aim_map... même si y'avait amx c'était INJOUABLE. J'ai même eu des erreurs cl_flushentitiypack qui m'empechait de faire quoi que ce soit.

J'arrête cs tant que j'ai pas régler ca moi -__-

Link to comment
Share on other sites

Alors après plusieurs test voici les résultats :

- nettoyage de l'unité central (qui avait beaucoup de poussière je l'avoue), toujours les bugs.

- arrêt de l'antivirus, toujours les bugs.

Serait-ce ma souris ? J'ai remarqué qu'elle n'était pas tout à fait fluide en allant vers le bas à droite.

- donc mise à jour du firmware et driver de ma souris razer lachesis (au cas où), toujours rien.

- passé les ports usb en 1000Hz au lieu des 125Hz de base, toujours rien... grrr.

En rejouant j'ai remarqué que dès fois, quand je fais des pas latéral gauche (ou droite) et que je veux bouger la souris en même temps pour viser un adversaire, le pointeur ne bouge pas (c'est embêtant).

Autre chose je ne sais pas si c'est normal : en regardant bien, le fps ne reste pas toujours à 99, il descend lors des smoke (normal), et qu'il y ait du monde ou non il descend à certains endroit dans la map (là en locurence dust2). Quand je suis respaw CT et que je regarde vers A pas de problème fps 99, par contre je regarde vers B fps vers les 50 ?

Je n'en puis plus, que faire !!!

PS : Sinon mon pote m'a pas dit de prendre une carte graphique à 200€, il m'a suggéré que si je voulais changer la config, ça serait intéressant de changer la carte mère (et processeur) en même temps parce que la mienne n'a pas de port pci ; et comme les carte graphique sont maintenant équipé en pci, ça serait dommage de prendre aujourd'hui une carte graphique agp et devoir la rechanger dans un an si je souhaite faire évoluer ma bécane ; et donc il m'a dit que pour 200€ environ je pouvais avoir une config sympa.

Link to comment
Share on other sites

En fait il doit y avoir un soucis avec les fps, je viens de jouer et il était assez bas (bon c'était sur une iceworld_xxl mais ça devrait bien tourner quand même je pense)... dans tous les cas je n'arrive toujours pas à régler mon problème... ahlàlà quelle joie quand je pourrai fragger tranquillou :D

voici l'imprim écran : fps.th.jpg

Link to comment
Share on other sites

bah si c'est une carte intégrée il faudrait essayer de jouer avec une carte séparée de ta carte mère (mais pas besoin de mettre 200€ dedans...)

C'est quoi EXACTEMENT ta carte ?[/quotemsg]

Si tu pouvais répondre à cette question ça serait cool.

pour ta souris, rajoute ces paramètres de lancement à ton jeu :

-noforcemaccel -noforcemparms -noforcemspd

Tu peux aussi essayer de modifier tes paramètres vidéos avancés et de baisser tout ce que tu peux pour avoir les meilleures performances.

Tu peux trouver une carte AGP pour 20€ et tu auras 100fps quasi tout le temps, donc changer de CM pour jouer à un jeu qui a 10 ans, c'est très très con.

Autant acheter un nouveau pc pour 400€ à mon avis.

Link to comment
Share on other sites

J'en ai marre j'en peux plus là ça me s....

Bon, j'ai remis les pilotes à jour = pas ça,

J'ai rentrer les paramètres de lancement du jeu -noforcemaccel -noforcemparms -noforcemspd = pas ça,

J'ai augmenté la cadence de mon écran à 75Hz (je peux pas plus) = pas ça non plus

J'ai mis toutes les configurations graphique au minimum, plus bas y'a plus = c'est toujours pas ça

Par contre je confirme bien que les fps descendent souvent vers 40- 50-60 quand je joue (ou même en spectateur aussi).

Je vous remercie par avance pour vos réponse (et de ton aide depuis le début ThEBiShOp) mais j'ai bien peur de ne pas trouver...je sens que la finalité sera le changement de ma tour, même si je trouve ça bête parce que je pense que ma config actuelle est amplement suffisante pour jouer à cs... mais bon là j'en ai marre !!!

Merci ;)

Link to comment
Share on other sites

les commandes noforce n'ont pas pour but de résoudre ton problème de fps, mais ton problème de souris.

Regarde l'utilisation de tes ressources, peut être que tu as trop d'application qui tournent, une bonne analyse sur hijackthis ne serait pas du luxe.

Mais tu sais, avant de penser à acheter une tour, essaye déjà de réinstaller windows, des fois on a des trucs bizarres à cause de certaines configurations logicielles...

Link to comment
Share on other sites

Régler le problême en ajoutant une ligne de commande sur le cmd.exe et en mettant en priorité basse steam.exe ( et donc hl.exe )

Essaye déja de mettre la priorité basse sur steam pour voir si ca change quelque chose , la ligne a ajouté dans le cmd.exe faut que je la retrouve sur le forum de steampowered.

Link to comment
Share on other sites

J'ai fais une analyse avec hijackthis, j'ai regardé ce que disait le rapport sur "http://www.hijackthis.de/fr#anl" mais j'ai pas trop compris le résultat. Ci-dessous le rapport.

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 23:34:09, on 23/12/2009

Platform: Windows XP SP2 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

Boot mode: Normal

Running processes:

C:\WINDOWS\System32\smss.exe

C:\WINDOWS\system32\winlogon.exe

C:\WINDOWS\system32\services.exe

C:\WINDOWS\system32\lsass.exe

C:\WINDOWS\system32\Ati2evxx.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\System32\svchost.exe

C:\WINDOWS\system32\Ati2evxx.exe

C:\WINDOWS\Explorer.EXE

C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe

C:\Program Files\Alwil Software\Avast4\ashServ.exe

C:\Program Files\Analog Devices\SoundMAX\SMTray.exe

C:\Program Files\Fichiers communs\InstallShield\UpdateService\issch.exe

C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe

C:\Program Files\Java\jre6\bin\jusched.exe

C:\Program Files\Razer\Lachesis\razerhid.exe

C:\WINDOWS\system32\ctfmon.exe

C:\Program Files\ATI Technologies\ATI.ACE\Core-Static\MOM.exe

C:\Program Files\ATI Technologies\ATI.ACE\Core-Static\ccc.exe

C:\WINDOWS\system32\spoolsv.exe

C:\Program Files\Java\jre6\bin\jqs.exe

C:\Program Files\Razer\Lachesis\OSD.exe

C:\Program Files\Analog Devices\SoundMAX\SMAgent.exe

C:\Program Files\Razer\Lachesis\razertra.exe

C:\Program Files\Razer\Lachesis\razerofa.exe

C:\WINDOWS\System32\svchost.exe

C:\WINDOWS\System32\StkASv2K.exe

C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe

C:\Program Files\Alwil Software\Avast4\ashWebSv.exe

C:\WINDOWS\system32\wscntfy.exe

C:\Program Files\Mozilla Firefox\firefox.exe

c:\progra~1\fichie~1\instal~1\update~1\isuspm.exe

C:\PROGRA~1\FICHIE~1\INSTAL~1\UPDATE~1\agent.exe

C:\Program Files\Steam\Steam.exe

C:\Documents and Settings\denis-60\Bureau\HiJackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.google.fr/

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Liens

O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 5.0\Reader\ActiveX\AcroIEHelper.ocx

O2 - BHO: (no name) - {5C255C8A-E604-49b4-9D64-90988571CECB} - (no file)

O2 - BHO: Programme d'aide de l'Assistant de connexion Windows Live - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Fichiers communs\Microsoft Shared\Windows Live\WindowsLiveLogin.dll

O2 - BHO: Java Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files\Java\jre6\bin\jp2ssv.dll

O2 - BHO: JQSIEStartDetectorImpl - {E7E6F031-17CE-4C07-BC86-EABFE594F69C} - C:\Program Files\Java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll

O4 - HKLM\..\Run: [smapp] C:\Program Files\Analog Devices\SoundMAX\SMTray.exe

O4 - HKLM\..\Run: [NeroFilterCheck] C:\WINDOWS\system32\NeroCheck.exe

O4 - HKLM\..\Run: [iSUSPM Startup] C:\PROGRA~1\FICHIE~1\INSTAL~1\UPDATE~1\isuspm.exe -startup

O4 - HKLM\..\Run: [iSUSScheduler] "C:\Program Files\Fichiers communs\InstallShield\UpdateService\issch.exe" -start

O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre6\bin\jusched.exe"

O4 - HKLM\..\Run: [KernelFaultCheck] %systemroot%\system32\dumprep 0 -k

O4 - HKLM\..\Run: [Lachesis] C:\Program Files\Razer\Lachesis\razerhid.exe

O4 - HKLM\..\Run: [startCCC] "C:\Program Files\ATI Technologies\ATI.ACE\Core-Static\CLIStart.exe" MSRun

O4 - HKCU\..\Run: [MSMSGS] "C:\Program Files\Messenger\msmsgs.exe" /background

O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe

O4 - HKUS\S-1-5-19\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'SERVICE LOCAL')

O4 - HKUS\S-1-5-20\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'SERVICE RÉSEAU')

O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'SYSTEM')

O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] C:\WINDOWS\System32\CTFMON.EXE (User 'Default user')

O8 - Extra context menu item: E&xporter vers Microsoft Excel - res://C:\PROGRA~1\MICROS~3\Office12\EXCEL.EXE/3000

O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~3\Office12\REFIEBAR.DLL

O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe (file missing)

O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe (file missing)

O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software - C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe

O23 - Service: Ati HotKey Poller - ATI Technologies Inc. - C:\WINDOWS\system32\Ati2evxx.exe

O23 - Service: ATI Smart - Unknown owner - C:\WINDOWS\system32\ati2sgag.exe

O23 - Service: avast! Antivirus - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashServ.exe

O23 - Service: avast! Mail Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe

O23 - Service: avast! Web Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashWebSv.exe

O23 - Service: Java Quick Starter (JavaQuickStarterService) - Sun Microsystems, Inc. - C:\Program Files\Java\jre6\bin\jqs.exe

O23 - Service: SoundMAX Agent Service (SoundMAX Agent Service (default)) - Analog Devices, Inc. - C:\Program Files\Analog Devices\SoundMAX\SMAgent.exe

O23 - Service: Syntek STK1160 Service (StkASSrv) - Syntek America Inc. - C:\WINDOWS\System32\StkASv2K.exe

--

End of file - 5389 bytes

Merci beaucoup

PS : vous pensez aussi qu'en mettant steam en priorité basse ça pour pourrait régler mon problème ?

Link to comment
Share on other sites

Si je peux ajouter mon grain de sel, je me permet quelques remarques :

Tu ne trouveras pas de carte AGP à moins de 50€, puisque c'est une denrée rare, évoluer ton PC pour 200€ semble une bonne idée, puisque c'est clairement un problème logiciel sur ton ordinateur qui provoque tes problèmes, ta tour SUFFISAIT à faire tourner CS, mais avec l'arrivée de Steam, et d'un tas d'autre applications sur ton PC, ce n'est plus le cas.

Un simple formatage règlerait sans doute la plupart de tes problèmes, avec une installation propre. J'avais la même config que toi à deux ou trois trucs près (CPU/CG identique). Je pense que si ta souris est USB, ce que tu sembles dires puisque tu parle de la fréquence des ports USB, ça explique les problèmes, car sur les vieilles machines et le USB1, il est assez facile de saturer d'informations un processeur un peu poussif.

Là où je suis plus circonspect, c'est sur tes "lags/freeze" quand un coéquipiers est proche de toi.

Il faudrait que tu essayes de changer tes "rates", en nous donnant d'abord les valeurs de celles-ci.

Les commandes à taper dans la console pour récupérer les valeurs sont :

cl_cmdrate

cl_updarate

rate

En principe, il faut commencer par la valeur la plus haute de cl_cmdrate et cl_updaterate (100), et descendre jusqu'à ne plus avoir de loss et de choke dans le net_graph 3 (conseillé).

De nos jours, la plupart des connexions tiennent la valeur la plus haute.

Rate est la bande passante totale allouée au jeu, en bits, donc 25kbs pour CS lorsqu'on met "rate 25000", ce qui est la valeur la plus courante. A moins que tu n'arrives pas à télécharger à plus que ce débit, et que ta ligne sature, je te conseille de mettre rate 25000.

Egalement, en accord avec ses rates, il faut configurer son ex_interp.

Ex_interp est l'interpolation des données réseaux reçu, c'est une fréquence qui détermine la précision des données affichées à l'écran.

Par défaut, la valeur est Ex_interp 0.1, ce qui est une hérésie, puisque c'est comme si tu bridais ta connexion à 10 envois de données et 10 réceptions par seconde. autrement dit, tous les 100ms, tu interprète et envoi un paquet de données, tout, le reste du temps ce que tu vois est "interpolé". Il faut donc mettre cette valeur à entre 0.020 et 0.010.

Bon, j'ai étalé ma "science", en espérant t'avoir au moins éclairé sur le netcode de CS (et du moteur de jeu GOLDsrc en général)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.