Bind Marcher/Courir


jothekileur

Recommended Posts

Bonjour tous le monde.

Alors, déjà, je precise que je jouais a CS1.6 et je me suis mis a CSS depuis peu.

J'ai donc repris mes binds de 1.6 en y apportant quelques modifications pour que sa tourne sur CSS bien sur. Mais j'ai un souci avec mon Bind Courir/Marcher.

Logiquement, si j'appuie sur le bouton 3 de la souris une fois, je marche. Si je re appuie je me remet a courir. Cela fonctionne mais apres X temps, je ne fais que marcher et même en reappuyant sur le bouton 3 sa ne re cours pas donc au final je marche tout le temps, meme si je me fais tuer, au prochain round idem. Même si je me reconnecte au serveur (ou so je change) idem.

J'ai essayer de faie un bind d'une autre touche pour recourir (+speed) mais cela ne fonctionne pas :(

Mon bind est le suivant:

===

Dans config.cfg:

bind "MOUSE3" "speed"

Dans userconfig.cfg:

/ Marcher/courir

//--

alias "speed" "mode_marcher"

alias "mode_marcher" "+speed; wait; alias speed mode_courir"

alias "mode_courir" "-speed; wait; alias speed mode_marcher"

===

Sur 1.6, j'ai jamais eu de problemes avec cela..

Si quelqu'un a une solution..

Merci d'avance pour vos futurs reponses.

PS: J'ai déjà effectué une rechercher mais le poste qui en parler ne m'a pas aider...

Link to comment
Share on other sites

le souci vient (je pense) du fait que tu essaies de surcharger la commance speed !

et oui, l'alias "speed" est réservé par CSS, c'est la commande qui dit au jeu de marcher ou courrir

toi tu essaies de le redéfinir, forcément ça pose souci

essaies plutot ca

alias "marche_cours" "mode_marcher"

alias "mode_marcher" "+speed; wait; alias marche_cours mode_courir"

alias "mode_courir" "-speed; wait; alias marche_cours mode_marcher"

edit : j'oubliais ca :

bind "MOUSE3" "marche_cours"

Link to comment
Share on other sites

  • 6 years later...

Archived

This topic is now archived and is closed to further replies.